How to fix PHP 7.1.3+ is required. Currently installed version is: 5.6.40

2003
AZDIGI Hosting Số 1 Việt Nam

Một số trường hợp khi bạn thực hiện truy cập vào phpMyAdmin để quản trị database tuy nhiên khi truy cập vào https://ip/phpmyadmin bạn nhận ngay thông báo PHP 7.1.3+ is required. Currently installed version is: 5.6.40 và không thể nào truy cập được, đây là một cảnh báo không phải lỗi hay gì cả.

php vestacp

Cách xử lý cũng khá đơn giản và bạn cần thực hiện là cài lại phpMyAdmin với phiên bản khác như yêu cầu là được.

Trước tiên bạn cần kiểm tra phpMyAdmin được get ở đâu nha, với bài viết này mình đang làm trên VestaCP thì mình sẽ sử dụng lệnh sau

cat /etc/nginx/conf.d/phpmyadmin.inc

php vestacp 1

Tại đây bạn thấy alias đến     /usr/share/phpMyAdmin/ và bạn cần truy cập vào thư mục này và change name thư mục phpMyAdmin đi để tải phpMyadmin mới về.

mv /usr/share/phpMyAdmin /usr/share/phpMyAdmin-old

Tuy thuộc vào phiên bản bạn cài đặt mà nhập wget và unzip cho tương ứng, không phải nhập y chang mình nhé. Nếu sử dụng phiên bản giống mình thì có thể nhập vào như vậy.

[root@sv share]# wget https://files.phpmyadmin.net/phpMyAdmin/4.9.1/phpMyAdmin-4.9.1-all-languages.zip
[root@sv share]# unzip phpMyAdmin-4.9.1-all-languages.zip
[root@sv share]# mv phpMyAdmin-4.9.1-all-languages phpMyAdmin

Sau khi thực hiện xong bạn hãy truy cập lại nhé

php vestacp 2

 

Chúc bạn thực hiện thành công

Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments